Incident
Incident Report for Forget Me Not
Resolved
Update to version 1.9.6 released. All bugs should be fixed, if you still encounter any problem contact us on our support page.
Posted Jul 04, 2021 - 09:39 UTC
Investigating
We're aware that some features related to "Watch" in version 1.9.5 are currently not working as intended, we'll be releasing a fix in the next couple of days
Posted Jul 03, 2021 - 21:20 UTC